标题:做了很多遍 运行结果是对的 提交却不对。高手们来看看错哪了。
取消只看楼主
蔡玉婷
Rank: 1
等 级:新手上路
帖 子:3
专家分:0
注 册:2012-11-3
 问题点数:0 回复次数:0 
做了很多遍 运行结果是对的 提交却不对。高手们来看看错哪了。
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

The input file will consist of several cases.Each case will be presented by an integer n (1<=n<20000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

For each case, output an integer in a line, which is the card number of your present.


 Sample Input
5
1 1 3 2 2
3
1 2 1
0 Sample Output
3
2

这是我做的  错在哪了,谢谢教导!
#include<stdio.h>
int main()
 {  int i,j,n,a[50];
while(scanf("%d",&n)!=EOF&&n!=0)
{ j=n/2+1;
    for(i=1;i<=n;i++)
    {    scanf("%d",&a[i]);
        if(i==j)
        printf("%d\n",a[j]);
    }

}
return 0;
}
搜索更多相关主题的帖子: numbers example present different one 
2012-11-03 19:42



参与讨论请移步原网站贴子:https://bbs.bccn.net/thread-385798-1-1.html




关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.552376 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved