标题:求解一个类似于斐波拉契数列的问题
只看楼主
Maple1992
Rank: 1
等 级:新手上路
帖 子:8
专家分:1
注 册:2011-11-5
结帖率:50%
 问题点数:0 回复次数:0 
求解一个类似于斐波拉契数列的问题
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

我的程序是这样的,但提交到OJ却显示Memory Limit Exceeded,超过内存限制,求各位大神教教小弟怎么修改?还有这种类似问题应该怎么做才能避免超内存呢?
#include<stdio.h>
int k[100000001];
int main()
{
  int a,b,n,i;
  while(scanf("%d %d %d",&a,&b,&n)==3,a!=0||b!=0||n!=0)
  {
  k[0]=1;
  k[1]=1;
  for(i=2;i<100000001;i++)
  {
  k[i]=(a*k[i-1]+b*k[i-2])%7;
  }
  printf("%d\n",k[n-1]);
  }
  return 0;
}
 
搜索更多相关主题的帖子: multiple single sequence number 
2012-04-03 14:23



参与讨论请移步原网站贴子:https://bbs.bccn.net/thread-365093-1-1.html




关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.301317 second(s), 8 queries.
Copyright©2004-2025, BCCN.NET, All Rights Reserved